upgpkg: ocaml-ctypes 0.20.2-1
[arch-packages.git] / kwin / trunk / PKGBUILD
blob8e0422eb09050c4daeb9a1d951c8da94f1486597
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kwin
6 pkgver=5.27.5
7 _dirver=$(echo $pkgver | cut -d. -f1-3)
8 pkgrel=2
9 pkgdesc='An easy to use, but flexible, composited Window Manager'
10 arch=(x86_64)
11 url='https://kde.org/plasma-desktop/'
12 license=(LGPL)
13 depends=(kscreenlocker xcb-util-cursor plasma-framework kcmutils breeze
14          pipewire-session-manager libqaccessibilityclient lcms2 libxcvt)
15 makedepends=(extra-cmake-modules qt5-tools kdoctools krunner wayland-protocols plasma-wayland-protocols python)
16 optdepends=('maliit-keyboard: virtual keyboard for kwin-wayland')
17 replaces=(kwayland-server)
18 groups=(plasma)
19 source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig}
20         https://invent.kde.org/plasma/kwin/-/commit/2237391e.patch)
21 install=$pkgname.install
22 sha256sums=('bb1226b15919681ea5f1de58b24ea4b568ea3f2b5452411f76daa80eb30c20ea'
23             'SKIP'
24             'ab43b696a25ab0f791bfe9889170027f753a3aaa1ecfeed65440497e944cf5e1')
25 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
26               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
27               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
28               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
30 prepare() {
31   patch -d $pkgname-$pkgver -p1 < 2237391e.patch # Fix scaling of XWayland apps
34 build() {
35   cmake -B build -S $pkgname-$pkgver \
36     -DCMAKE_INSTALL_LIBEXECDIR=lib \
37     -DBUILD_TESTING=OFF
38   cmake --build build
41 package() {
42   DESTDIR="$pkgdir" cmake --install build