upgpkg: ocaml-ctypes 0.20.2-1
[arch-packages.git] / libchamplain / repos / extra-x86_64 / PKGBUILD
blob4a9a69edf321284171c0f0d174a619ec7995051a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Andreas Radke <andyrtr@archlinux.org>
3 # Contributor: Michael Kanis <mkanis@gmx.de>
5 pkgname=libchamplain
6 pkgver=0.12.21
7 pkgrel=1
8 pkgdesc="Map widget for GTK 3"
9 url="https://wiki.gnome.org/Projects/libchamplain"
10 license=(LGPL)
11 arch=(x86_64)
12 depends=(clutter-gtk libsoup3 cairo sqlite)
13 makedepends=(gobject-introspection gtk-doc vala meson git)
14 _commit=941560af497148588783db991e8135f52a82574d  # tags/0.12.21^0
15 source=("git+https://gitlab.gnome.org/GNOME/libchamplain.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/^LIBCHAMPLAIN_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build -D gtk_doc=true
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"
40 # vim:set sw=2 sts=-1 et: