upgpkg: ocaml-ctypes 0.20.2-1
[arch-packages.git] / tinycdb / trunk / PKGBUILD
blobc54755fb90bfbcf1ba50770993d31993b78964c4
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
5 pkgname=tinycdb
6 pkgver=0.78
7 pkgrel=6
8 pkgdesc='Very fast and simple package for creating and reading constant data bases'
9 arch=(x86_64)
10 url="https://www.corpit.ru/mjt/tinycdb.html"
11 license=(custom)
12 depends=(glibc)
13 provides=(libcdb.so)
14 # we don't want libcdb.a and would need to modify the Makefile otherwise
15 options=(!staticlibs)
16 source=(https://www.corpit.ru/mjt/tinycdb/$pkgname-$pkgver.tar.gz)
17 sha512sums=('8930086b8e7fddcd4dbd3354c5f5ee05171df68fde1cc222b6c402430042b6e761efbad7e5fa8de18e1d36390f1526cc3e605c5086fe1c363ba1df6c03201553')
18 b2sums=('41f4256840645acd28296c5473087c7cf4c026f068310375b3c305430c030b1c946f53fd3e09967d77b592ba84e7e56518fdb18e54d1e0f5e7dd552a1664a0ec')
20 build() {
21   local make_options=(
22     CFLAGS="$CFLAGS"
23     LDFLAGS="$LDFLAGS"
24     all
25     shared
26     -C $pkgname-$pkgver
27   )
29   make "${make_options[@]}"
32 package() {
33   local make_options=(
34     DESTDIR="$pkgdir"
35     prefix=/usr
36     mandir=/usr/share/man
37     INSTALLPROG=cdb-shared
38     install-{all,sharedlib}
39     -C $pkgname-$pkgver
40   )
42   make "${make_options[@]}"
43   install -vDm 644 $pkgname-$pkgver/debian/copyright -t "$pkgdir/usr/share/licenses/$pkgname/"
44   install -vDm 644 $pkgname-$pkgver/{NEWS,ChangeLog} -t "$pkgdir/usr/share/doc/$pkgname/"