upgpkg: ocaml-ctypes 0.20.2-1
[arch-packages.git] / uhttpmock / trunk / PKGBUILD
blob0456e014b0deca81a9f80ce8a3a26902c57991db
1 # Maintainer:
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=uhttpmock
5 pkgver=0.9.0
6 pkgrel=1
7 pkgdesc="HTTP web service mocking project for projects which use libsoup"
8 url="https://gitlab.freedesktop.org/pwithnall/uhttpmock"
9 depends=('glib2' 'libsoup3')
10 makedepends=('meson' 'gtk-doc')
11 license=('LGPL2.1')
12 arch=(x86_64)
13 source=(https://gitlab.freedesktop.org/pwithnall/uhttpmock/-/archive/$pkgver/uhttpmock-$pkgver.tar.gz)
14 sha256sums=('9fbcdcbc3e4b1ccde2281e3010f169036862423c936ffc8904ab30daad474b07')
16 build() {
17   meson build $pkgname-$pkgver \
18     --prefix=/usr \
19     -D introspection=false
20   meson compile -C build
23 package() {
24   meson install -C build --destdir="$pkgdir"