2.0.2-2: libplist 2.3.0
[arch-packages.git] / perl-lwp-protocol-https / trunk / PKGBUILD
blobd76c8bc4e0151ae65f3b230f2f9a8ddc9895da99
1 # Maintainer: Felix Yan <felixonmars@gmail.com>
3 pkgname=perl-lwp-protocol-https
4 pkgver=6.10
5 pkgrel=4
6 pkgdesc="Provide https support for LWP::UserAgent"
7 arch=('any')
8 url="https://metacpan.org/release/LWP-Protocol-https"
9 license=('PerlArtistic' 'GPL')
10 depends=('ca-certificates' 'perl-io-socket-ssl' 'perl-mozilla-ca' 'perl-net-http' 'perl-libwww')
11 checkdepends=('perl-test-requiresinternet')
12 options=('!emptydirs')
13 source=("https://search.cpan.org/CPAN/authors/id/O/OA/OALDERS/LWP-Protocol-https-$pkgver.tar.gz")
14 sha512sums=('4d3c89dab6fadcb574c176977ca6debba177ee3f817e87319d9cd81e0a0b09214e271c2e97edc456dad2f4a1ebf8c6266a4ae52c3a93144880a5b32db97e7a31')
16 build() {
17   cd LWP-Protocol-https-$pkgver
18   perl Makefile.PL INSTALLDIRS=vendor
19   make
22 check() {
23   cd LWP-Protocol-https-$pkgver
24   make test
27 package() {
28   cd LWP-Protocol-https-$pkgver
29   make DESTDIR="$pkgdir" install