2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: PedsXing <pedsxing at gmx dot net>
8 pkgdesc='A library to ease explicit vectorization of C++ code'
9 url='https://github.com/VcDevel/Vc'
13 source=(https://github.com/VcDevel/Vc/releases/download/$pkgver/Vc-$pkgver.tar.gz)
14 sha256sums=('988ea0053f3fbf17544ca776a2749c097b3139089408b0286fa4e9e8513e037f')
17 cmake -B build -S Vc-$pkgver \
18 -DCMAKE_INSTALL_PREFIX=/usr \
19 -DCMAKE_CXX_FLAGS="$CXXFLAGS -ffat-lto-objects" \
20 -DTARGET_ARCHITECTURE=generic
25 DESTDIR="$pkgdir" cmake --install build