1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
6 pkgdesc="A tool for generating C bindings to Rust code"
7 url="https://github.com/eqrion/cbindgen"
11 makedepends=(cargo git)
13 _commit=41506d5aeb2be8d200f52d08afb0c243414eb00d # tags/v0.20.0^0
14 source=("git+https://github.com/eqrion/cbindgen#commit=$_commit")
19 git describe --tags | sed 's/^v//;s/-/+/g'
24 cargo fetch --locked --target x86_64-unknown-linux-gnu
29 cargo build --release --frozen --all-targets
34 # Tests need nightly features
35 RUSTC_BOOTSTRAP=1 cargo test --release --frozen
40 install -Dt "$pkgdir/usr/bin" target/release/cbindgen
41 install -Dt "$pkgdir/usr/share/doc/$pkgname" -m644 README.md