1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
6 pkgdesc="A GTK+ based e-mail client"
9 url="https://www.claws-mail.org"
10 depends=('gtk3' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
11 'libetpan' 'compface' 'libsm' 'dbus-glib')
12 makedepends=('spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
13 # dependencies for plugins
14 'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'libytnef' 'libical'
15 'dillo' 'python' 'gumbo-parser'
16 # deps to build the docs
17 'docbook-utils' 'texlive-formatsextra')
18 optdepends=('python: needed for some tools'
19 'perl: needed for some tools and perl plugin'
20 'spamassassin: adds support for spamfiltering'
21 'bogofilter: adds support for spamfiltering'
22 'libnotify: for notification plugin'
23 'libcanberra: for notification plugin'
24 'dbus: for notification plugin'
25 'libxml2: for rssyl plugins'
26 'curl: for vcalendar, rssyl and spamreport plugins'
27 'libarchive: for archive plugin and various other plugins'
28 'libytnef: for tnef_parse plugin'
29 'libgdata: for gdata plugin'
30 'poppler-glib: for pdf viewer plugin'
31 'ghostscript: for pdf viewer plugin'
32 'libical: for vcalendar plugin'
33 'dillo: for dillo html viewer plugin'
34 'webkit2gtk: for fancy webkit html viewer plugin'
35 'gumbo-parser: for litehtml plugin')
37 install=$pkgname.install
38 source=(https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
39 0001_move_OAuth2_to_last_place_in_auto_auth_selection.diff
40 0002_Fancy_crashes_when_opening_an_email.diff
42 sha256sums=('4af2bd26a5d91eacb2a9c09f67a6a46c2222b40817c1f525dc050bdc7b0ee475'
44 'ffd5dfe8929a86667218512095a794263a2ae56fae4add83d3ad987f94e7f786'
45 'f56256a9535958063b966ab52abdf787422ff71ed2a5c41b3d9fea8716defe85'
46 '3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
47 validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
51 cd "${pkgname}"-${pkgver}
53 patch -Np1 -i ../0001_move_OAuth2_to_last_place_in_auto_auth_selection.diff
54 patch -Np1 -i ../0002_Fancy_crashes_when_opening_an_email.diff
58 cd "${pkgname}"-${pkgver}
59 ./configure --prefix=/usr --disable-static \
63 --enable-crash-dialog \
64 --enable-pgpmime-plugin \
65 --enable-spamassassin-plugin \
66 --enable-bogofilter-plugin \
67 --enable-fancy-plugin \
69 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
74 cd "${pkgname}"-${pkgver}
75 make DESTDIR="${pkgdir}" install
77 install -Dm 644 "$srcdir"/bash_completion "${pkgdir}"/usr/share/bash-completion/completions/claws-mail
81 install -m755 -d "${pkgdir}"/usr/lib/claws-mail/tools
82 for files in *.pl *.py *.sh *.conf tb2claws-mail update-po uudec uuooffice README; do
83 cp -arv $files "${pkgdir}"/usr/lib/claws-mail/tools/