1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=flatpak-builder
6 pkgdesc="Tool to build flatpaks from source"
7 url="https://flatpak.org"
10 depends=(flatpak binutils elfutils unzip tar git bzr patch rpmextract cpio appstream-glib)
11 makedepends=(intltool gobject-introspection git docbook-xsl xmlto libdwarf)
12 checkdepends=(valgrind)
13 replaces=('flatpak<0.9.10')
14 _commit=ade6de21f7379886460b683810628a0a441be924 # tags/1.2.0^0
15 source=("git+https://github.com/flatpak/flatpak-builder#commit=$_commit"
16 "git+https://gitlab.gnome.org/GNOME/libglnx.git"
17 "git+https://sourceware.org/git/debugedit.git")
26 git submodule set-url libglnx "$srcdir/libglnx"
27 git submodule set-url debugedit "$srcdir/debugedit"
30 # https://github.com/flatpak/flatpak/issues/267
31 sed -i '/locale\/C\./d' tests/make-test-runtime.sh
33 NOCONFIGURE=1 ./autogen.sh
38 git describe --tags | sed 's/-/+/g'
47 --localstatedir=/var \
49 --libexecdir=/usr/lib \
51 --with-dwarf-header=/usr/include/libdwarf
53 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
65 make DESTDIR="$pkgdir" install