sbcl 2.1.11 rebuild
[arch-packages.git] / gfbgraph / trunk / PKGBUILD
blob72429cb675ebdfb3f7e94ab928958baef7a78432
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
4 pkgname=gfbgraph
5 pkgver=0.2.5
6 pkgrel=1
7 pkgdesc="GLib/GObject wrapper for the Facebook Graph API"
8 url="https://wiki.gnome.org/Projects/GFBGraph"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(gnome-online-accounts)
12 makedepends=(rest json-glib gobject-introspection gtk-doc git)
13 _commit=b5ccfc1195c89850b009966abc70a97abdb50a72
14 source=("git+https://gitlab.gnome.org/GNOME/libgfbgraph.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd libgfbgraph
19   git describe --tags | sed 's/^v_//;s/_/./g;s/-/+/g'
22 prepare() {
23   cd libgfbgraph
24   NOCONFIGURE=1 ./autogen.sh
27 build() {
28   cd libgfbgraph
29   ./configure --prefix=/usr \
30     --disable-static \
31     --enable-gtk-doc \
32     --enable-introspection
33   sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
34   make
37 package() {
38   cd libgfbgraph
39   make DESTDIR="$pkgdir" install \
40     libgfbgraphdocdir=/usr/share/doc/$pkgname