1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Mantas Mikulėnas <grawity@gmail.com>
9 url="https://github.com/gssapi/gssproxy"
10 license=('custom: MIT')
11 depends=('krb5' 'popt' 'ding-libs')
12 makedepends=('libxslt' 'systemd' 'docbook-xsl' 'doxygen' 'po4a')
13 options=('emptydirs' 'makeflags')
14 backup=(etc/gssproxy/{gssproxy,24-nfs-server,80-httpd,99-nfs-client}.conf
15 etc/gss/mech.d/gssproxy.conf)
16 source=(https://github.com/gssapi/gssproxy/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
17 sha512sums=('ab81c40d6c7b1908751feb107d8da66603b7681fb67aa7a1f30194a81d542ca89e6c2f34425e9356b9c55eb3691bfa240ba41441c01498af45e862a133cd088a')
20 cd "$srcdir/gssproxy-$pkgver"
21 # delete unneeded service dependency
22 sed -i "/# GSSPROXY will not be started until syslog is/d" systemd/gssproxy.service.in
23 sed -i "s/syslog.target //" systemd/gssproxy.service.in
31 # make it find bundled verto from krb5 without its own pkg-config file
32 export VERTO_CFLAGS="-I/usr/include"
33 export VERTO_LIBS="-L/usr/lib -lverto"
35 ./configure --prefix=/usr \
37 --with-pubconf-path=/etc/gssproxy \
39 --localstatedir=/var \
41 --with-initscript=systemd \
42 --with-gpp-default-behavior=REMOTE_FIRST
55 make DESTDIR=$pkgdir install
57 # cleanup empty directories
58 rm -rf "$pkgdir"/usr/include
59 rm -rf "$pkgdir"/usr/share/doc
61 # install default config files
62 install -m644 examples/gssproxy.conf "$pkgdir"/etc/gssproxy/gssproxy.conf
64 install -m644 examples/24-nfs-server.conf "$pkgdir"/etc/gssproxy/24-nfs-server.conf
65 install -m644 examples/99-nfs-client.conf "$pkgdir"/etc/gssproxy/99-nfs-client.conf
66 # httpd service / use Arch UID/GID http/33 (by pkg filesystem)
67 install -m644 examples/80-httpd.conf "$pkgdir"/etc/gssproxy/80-httpd.conf
68 sed -i -e "s:euid = apache:euid = http:" "$pkgdir"/etc/gssproxy/80-httpd.conf
70 install -Dm644 examples/mech "$pkgdir"/etc/gss/mech.d/gssproxy.conf
73 install -m700 -d ${pkgdir}/var/lib/gssproxy/rcache
75 install -m755 -d ${pkgdir}/usr/share/licenses/$pkgname
76 install -m644 COPYING ${pkgdir}/usr/share/licenses/$pkgname/