1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: drakkan <nicola.murino at gmail dot com>
7 pkgdesc='Qt-based client-side and server-side SOAP component'
8 license=(GPL3 LGPL custom)
10 url='https://github.com/KDAB/KDSoap'
13 source=(https://github.com/KDAB/KDSoap/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz{,.asc})
14 sha256sums=('d18963104fa6f7d02b044631cddbe78f18f70e06c607af680c7ace04d6cf04ee'
16 validpgpkeys=(E86C000370B1B9E2A9191AD53DBFB6882C9358FB) # KDAB Products (user for KDAB products) <info@kdab.com>
19 cmake -B build -S $pkgname-$pkgver \
20 -DCMAKE_INSTALL_PREFIX=/usr \
21 -DCMAKE_BUILD_TYPE=None
26 DESTDIR="$pkgdir" cmake --install build
27 install -Dm644 $pkgname-$pkgver/LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname