sbcl 2.1.11 rebuild
[arch-packages.git] / ldb / trunk / PKGBUILD
blobc9a8ed9d7a647f7f237c02635a93a26a8c90fbce
1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
2 # Contributor: Christian Hesse <mail@eworm.de>
3 # Contributor: Marco A Rojas <marquicus at gmail dot com>
5 pkgname=ldb
6 pkgver=2.4.1
7 pkgrel=4
8 epoch=2
9 pkgdesc='Schema-less, ldap like, API and database'
10 arch=('x86_64')
11 url="https://ldb.samba.org/"
12 source=(https://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar{.gz,.asc})
13 license=('GPL3')
14 depends=('talloc' 'libtevent.so' 'tdb' 'libtdb.so' 'popt' 'lmdb')
15 makedepends=('python' 'cmocka' 'docbook-xsl' 'tevent')
16 optdepends=('python: for python bindings')
17 provides=(libldb.so)
18 validpgpkeys=('9147A339719518EE9011BCB54793916113084025') # Samba Library Distribution Key <samba-bugs@samba.org>
19 sha512sums=('14ab5397d28c369142b2ccf55a2ab4e678a3fe6e018541cfce46241f8226400bc169360bbef254fae4410a6e15024ae986f02298d3d324e3d3a8b88801bf76d7'
20             'SKIP')
22 build() {
23   cd ${pkgname}-${pkgver}
24   ./configure \
25     --prefix=/usr \
26     --disable-rpath \
27     --disable-rpath-install \
28     --bundled-libraries=NONE \
29     --builtin-libraries=replace \
30     --with-modulesdir=/usr/lib/ldb/modules \
31     --with-privatelibdir=/usr/lib/ldb
32   make
35 package() {
36   cd ${pkgname}-${pkgver}
37   make DESTDIR="${pkgdir}" install
40 # vim: ts=2 sw=2 et: