sbcl 2.1.11 rebuild
[arch-packages.git] / libportal / trunk / PKGBUILD
blob90a30b85d8ce30c5f8681776a75d939175f406ba
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2  
3 pkgname=libportal
4 pkgver=0.4
5 pkgrel=1
6 pkgdesc="GIO-style async APIs for most Flatpak portals"
7 url="https://github.com/flatpak/libportal"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(glib2)
11 makedepends=(git meson gtk-doc)
12 _commit=f68764e288ede516d902b131cc4fadded3804059  # tags/0.4^0
13 source=("git+https://github.com/flatpak/libportal#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed -r 's/[^-]+-g[^-]+$/r&/;s/-/+/g'
21 prepare() {
22   cd $pkgname
25 build() {
26   arch-meson $pkgname build
27   meson compile -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   meson install -C build --destdir "$pkgdir"
38 # vim:set sw=2 et: