sbcl 2.1.11 rebuild
[arch-packages.git] / perl-appconfig / repos / extra-any / PKGBUILD
blob723fd0ca650e4da45c60ce1b8680071b04b903b2
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: eric <eric@archlinux.org>
3 # Contributor: Eric Johnson <eric@coding-zone.com>
5 pkgname=perl-appconfig
6 pkgver=1.71
7 pkgrel=8
8 pkgdesc="Perl/CPAN AppConfig module - Read configuration files and parse command line arguments"
9 arch=('any')
10 license=('PerlArtistic' 'GPL')
11 url="https://search.cpan.org/dist/AppConfig/"
12 depends=('perl')
13 options=('!emptydirs')
14 source=("https://www.cpan.org/authors/id/N/NE/NEILB/AppConfig-$pkgver.tar.gz")
15 md5sums=('7747d9241561ed5567d5e134b8648707')
17 build() {
18   cd AppConfig-$pkgver
19   perl Makefile.PL INSTALLDIRS=vendor
20   make
23 check() {
24   cd AppConfig-$pkgver
25   make test
28 package() {
29   cd AppConfig-$pkgver
30   make install DESTDIR="$pkgdir"