db-move: moved webkit2gtk-4.1 from [testing] to [extra] (x86_64)
[arch-packages.git] / convertlit / trunk / PKGBUILD
blob5335207e1a301a09b368eeb446f26d808850262c
1 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
2 # Contributor: gDD (usrgdd | gmail)
3 # Contributor: cantabile
5 pkgname=convertlit
6 pkgver=1.8
7 pkgrel=11
8 pkgdesc='An extractor/converter for .LIT eBooks'
9 arch=(x86_64)
10 url='http://www.convertlit.com/'
11 license=(GPL)
12 depends=(libtommath)
13 source=(http://www.convertlit.com/clit18src.zip)
14 sha256sums=('d70a85f5b945104340d56f48ec17bcf544e3bb3c35b1b3d58d230be699e557ba')
16 prepare() {
17 # Link to shared libtommath and use system LDFLAGS
18   sed -i 's|../libtommath-0.30/libtommath.a|/usr/lib/libtommath.so ${LDFLAGS}|' clit18/Makefile
21 build() {
22   cd lib
23   make 
25   cd ../clit18
26   make
29 package() {
30   cd clit18
32   install -Dm755 clit "$pkgdir/usr/bin/clit"