db-move: moved webkit2gtk-4.1 from [testing] to [extra] (x86_64)
[arch-packages.git] / suitesparse / trunk / PKGBUILD
blob89763570fcf750a9b72c84430da13d4f26163b21
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Ronald van Haren <ronald.archlinux.org>
4 pkgbase=suitesparse
5 pkgname=(suitesparse suitesparse64)
6 pkgver=7.0.1
7 pkgrel=2
8 pkgdesc='A collection of sparse matrix libraries'
9 url='http://faculty.cse.tamu.edu/davis/suitesparse.html'
10 arch=(x86_64)
11 makedepends=(gcc-fortran cmake lapack lapack64)
12 license=(GPL)
13 source=(https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('dc2f8d5c2657c120b30cce942f634ec08fc3a4b0b10e19d3eef7790b2bec8d1e')
16 prepare() {
17   cp -r SuiteSparse-$pkgver SuiteSparse64
20 build() {
21   cd SuiteSparse-$pkgver
22   CXXFLAGS+=" -ffat-lto-objects" \
23   CMAKE_OPTIONS="-DBLA_VENDOR=Generic \
24   -DCMAKE_INSTALL_PREFIX=/usr \
25   -DCMAKE_BUILD_TYPE=None" \
26   make
28   cd ../SuiteSparse64
29   CXXFLAGS+=" -ffat-lto-objects" \
30   CMAKE_OPTIONS="-DBLA_VENDOR=Generic \
31   -DALLOW_64BIT_BLAS=ON \
32   -DCMAKE_INSTALL_PREFIX=/usr \
33   -DCMAKE_BUILD_TYPE=None" \
34   make
37 package_suitesparse() {
38   depends=(lapack mpfr)
40   cd SuiteSparse-$pkgver
41   DESTDIR="$pkgdir" make install
44 package_suitesparse64() {
45   pkgdesc+=' (compiled with BLAS64)'
46   depends=(lapack64 mpfr)
47   conflicts=(suitesparse)
48   provides=(suitesparse)
50   cd SuiteSparse64
51   DESTDIR="$pkgdir" make install