db-move: moved libdex from [staging] to [testing] (x86_64)
[arch-packages.git] / dbus-broker / trunk / PKGBUILD
blob7c720b6b4d5770532e207e69b5f84fef3eb19693
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: David Herrmann <dh.herrmann@gmail.com>
4 pkgname=dbus-broker
5 pkgver=33
6 pkgrel=1
7 pkgdesc="Linux D-Bus Message Broker"
8 url="https://github.com/bus1/dbus-broker/wiki"
9 arch=(x86_64)
10 license=(Apache)
11 depends=(
12   audit
13   expat
14   systemd-libs
16 makedepends=(
17   meson
18   python-docutils
19   systemd
21 source=(
22   https://github.com/bus1/dbus-broker/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz{,.asc}
24 sha256sums=('23713f25624749fdb274907e429080fa2d8f4dbe76acd87bb6d21a3c818c7841'
25             'SKIP')
26 validpgpkeys=(BE5FBC8C9C1C9F60A4F0AEAE7A4F3A09EBDEFF26) # David Herrmann <dh.herrmann@gmail.com>
28 prepare() {
29   cd $pkgname-$pkgver
32 build() {
33   local meson_options=(
34     -D audit=true
35     -D docs=true
36     -D linux-4-17=true
37     -D system-console-users=gdm,sddm,lightdm,lxdm
38   )
40   arch-meson $pkgname-$pkgver build "${meson_options[@]}"
41   meson compile -C build
44 check() {
45   meson test -C build --print-errorlogs
48 package() {
49   meson install -C build --destdir "$pkgdir"
52 # vim:set sw=2 sts=-1 et: