upgpkg: sbcl 2.2.4-1
[arch-packages.git] / hyphen-nl / repos / extra-any / PKGBUILD
blobd1139699274268489610fd092a89f89357cadf7b
1 # Contributor: Jelle van der Waa <jelle vdwaa nl>
3 pkgname=hyphen-nl
4 pkgver=20050617
5 pkgrel=5
6 pkgdesc="Dutch hyphenation rules"
7 arch=('any')
8 url="https://wiki.services.openoffice.org/wiki/Dictionaries#Dutch_.28Netherlands.29"
9 license=('GPL2')
10 optdepends=('hyphen: offers hyphenation library functions')
11 source=("https://www.mirrorservice.org/sites/download.openoffice.org/contrib/dictionaries/hyph_nl_NL.zip")
12 md5sums=('6f0b18ce830445ae8337df8913155196')
14 package() {
15   cd "${srcdir}"
16   install -dm755 "${pkgdir}/usr/share/hyphen"
17   install -m644 hyph_nl_NL.dic "${pkgdir}/usr/share/hyphen/hyph_nl_NL.dic"
19   pushd "${pkgdir}/usr/share/hyphen/"
20   nl_NL_aliases="nl_AW nl_BE"
21   for lang in ${nl_NL_aliases}; do
22         ln -s hyph_nl_NL.dic hyph_${lang}.dic
23   done
25   popd
27   # the symlinks
28   install -dm755 "${pkgdir}/usr/share/myspell/dicts"
29   pushd "${pkgdir}/usr/share/myspell/dicts"
30     for file in ${pkgdir}/usr/share/hyphen/*; do
31       ln -sv /usr/share/hyphen/$(basename ${file}) .
32     done
33   popd
35   # docs
36   install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
37   install -m644 README_hyph_nl_NL.txt "${pkgdir}/usr/share/doc/${pkgname}/README_hyph_nl_NL.txt"