1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Bartłomiej Piotrowski <barthalion@gmail.com>
3 # Contributor: Thomas S Hatch <thatch45 at gmail dot com>
8 pkgdesc="The Linux-native asynchronous I/O facility (aio) library"
10 url="https://pagure.io/libaio"
15 source=(https://pagure.io/libaio/archive/$pkgname-$pkgver/$pkgname-$pkgname-$pkgver.tar.gz)
16 sha512sums=('8058c927de0b5f7079fc232d2be23272537694bf271488af1dc0330b58afc307931792ab138512c5e00aa3ea921935a6d862f575fb0cc2bf323de63d8df208cd')
17 b2sums=('e06c1c1cc118c15f6bed1abfa97368d7ccc0d2e716a233cd4141936fb382e40909c340a6c882b18ee9461aaa23dd77a6644a38bdb5a00c1444538a2e0ab816d4')
20 # -Werror, not even once
21 sed 's/-Werror//' -i $pkgname-$pkgname-$pkgver/harness/Makefile
25 # libaio is a thin wrapper around kernel syscalls, it does not use stdlib and
26 # other helpers like stack protection libraries
27 CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe"
28 make -C $pkgname-$pkgname-$pkgver
32 make partcheck -k -C $pkgname-$pkgname-$pkgver
36 make DESTDIR="$pkgdir" install -C $pkgname-$pkgname-$pkgver
37 install -vDm 644 $pkgname-$pkgname-$pkgver/{ChangeLog,README.md} -t "$pkgdir/usr/share/doc/$pkgname/"
38 install -vDm 644 $pkgname-$pkgname-$pkgver/man/*.3 -t "$pkgdir/usr/share/man/man3/"