1 # Maintainer: Felix Yan <felixonmars@gmail.com>
3 pkgname=perl-lwp-protocol-https
6 pkgdesc="Provide https support for LWP::UserAgent"
8 url="https://metacpan.org/release/LWP-Protocol-https"
9 license=('PerlArtistic' 'GPL')
10 depends=('ca-certificates' 'perl-io-socket-ssl' 'perl-net-http' 'perl-libwww')
11 checkdepends=('perl-test-requiresinternet')
12 options=('!emptydirs')
13 source=("https://search.cpan.org/CPAN/authors/id/O/OA/OALDERS/LWP-Protocol-https-$pkgver.tar.gz"
15 sha512sums=('4d3c89dab6fadcb574c176977ca6debba177ee3f817e87319d9cd81e0a0b09214e271c2e97edc456dad2f4a1ebf8c6266a4ae52c3a93144880a5b32db97e7a31'
16 '96f401471199c368895eb9b0e819a7287ed9e25953f756585ef7e809010e5d19c8b0614f3cd99cad0c33ca7c9a609ceea4b90569d3f7dec546cc8eeecd810d26')
19 cd LWP-Protocol-https-${pkgver}
20 patch -p1 -i ../certs.patch
24 cd LWP-Protocol-https-${pkgver}
25 perl Makefile.PL INSTALLDIRS=vendor
30 cd LWP-Protocol-https-${pkgver}
35 cd LWP-Protocol-https-${pkgver}
36 make DESTDIR="$pkgdir" install