upgpkg: sbcl 2.2.4-1
[arch-packages.git] / tali / trunk / PKGBUILD
blob4e333e6154388bbbaef5aea1462321313868dd6a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=tali
5 pkgver=40.7
6 pkgrel=1
7 pkgdesc="Beat the odds in a poker-style dice game"
8 url="https://wiki.gnome.org/Apps/Tali"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 librsvg libgnome-games-support)
12 makedepends=(meson gobject-introspection yelp-tools appstream-glib git)
13 groups=(gnome-extra)
14 options=(debug)
15 _commit=5c05e7f6f0e6c7d33c5a7136ed8174473b01693a  # tags/40.7^0
16 source=("git+https://gitlab.gnome.org/GNOME/tali.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd tali
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd tali
28 build() {
29   arch-meson tali build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"