upgpkg: sbcl 2.2.4-1
[arch-packages.git] / xdg-dbus-proxy / trunk / PKGBUILD
blob5a3e5a810e33143e9ad1743e66a7fbcb995c4978
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
4 pkgname=xdg-dbus-proxy
5 pkgver=0.1.3
6 pkgrel=1
7 pkgdesc="Filtering proxy for D-Bus connections"
8 url="https://github.com/flatpak/xdg-dbus-proxy"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(glib2 dbus)
12 makedepends=(git autoconf-archive docbook-xsl)
13 _commit=75667790f1412a17b152fada45adad22c5840865  # tags/0.1.3^0
14 source=("git+$url#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 prepare() {
23   cd $pkgname
24   NOCONFIGURE=1 ./autogen.sh
27 build() {
28   cd $pkgname
29   ./configure --prefix=/usr
30   make
33 check() {
34   cd $pkgname
35   make check
38 package() {
39   cd $pkgname
40   make DESTDIR="$pkgdir" install