OCaml 4.14.0 rebuild
[arch-packages.git] / dbus-broker / trunk / PKGBUILD
blobe8b6f7c390a756108490b74096cd298a67a5ec35
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: David Herrmann <dh.herrmann@gmail.com>
4 pkgname=dbus-broker
5 pkgver=32
6 pkgrel=1
7 pkgdesc="Linux D-Bus Message Broker"
8 url="https://github.com/bus1/dbus-broker/wiki"
9 arch=(x86_64)
10 license=(Apache)
11 depends=(systemd-libs expat audit)
12 makedepends=(meson systemd python-docutils)
13 options=(debug)
14 source=(https://github.com/bus1/dbus-broker/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz)
15 sha256sums=('bea7f653e7251063c5f427e9e3f93562d38a0d8667ae6d49fb56f113605985de')
17 prepare() {
18   cd $pkgname-$pkgver
21 build() {
22   arch-meson $pkgname-$pkgver build \
23     -D audit=true \
24     -D docs=true \
25     -D linux-4-17=true \
26     -D system-console-users=gdm,sddm,lightdm,lxdm
27   meson compile -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   meson install -C build --destdir "$pkgdir"
38 # vim:set sw=2 et: