OCaml 4.14.0 rebuild
[arch-packages.git] / gdk-pixbuf-xlib / trunk / PKGBUILD
blobac18f642548e5352cfafda48198995b764e0f9f3
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gdk-pixbuf-xlib
4 pkgver=2.40.2
5 pkgrel=1
6 pkgdesc="Deprecated Xlib integration for GdkPixbuf"
7 arch=(x86_64)
8 url="https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib"
9 license=(LGPL2.1)
10 depends=(gdk-pixbuf2 libx11)
11 makedepends=(gtk-doc git meson)
12 _commit=c142b818801e0affceea4a2139cf5630a283e54e  # tags/2.40.2^0
13 source=("git+$url.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/-/+/g'
21 prepare() {
22   cd $pkgname
25 build() {
26   arch-meson $pkgname build -D gtk_doc=true
27   meson compile -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   depends+=(libgdk_pixbuf-2.0.so)
36   provides+=(libgdk_pixbuf_xlib-2.0.so)
38   DESTDIR="$pkgdir" meson install -C build
41 # vim:set sw=2 et: