OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-terminal / trunk / PKGBUILD
blob6cdd29364ca764f474ac8911967a31dfad87b6f6
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-terminal
5 pkgver=3.44.1
6 pkgrel=1
7 pkgdesc="The GNOME Terminal Emulator"
8 url="https://wiki.gnome.org/Apps/Terminal"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(vte3 gsettings-desktop-schemas)
12 makedepends=(docbook-xsl libnautilus-extension gnome-shell yelp-tools git meson)
13 groups=(gnome)
14 options=(debug)
15 _commit=8209fbeec17c835cb99708bcaf956b75b69cd7b3  # tags/3.44.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-terminal.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"