1 # Maintainer: Sébastien Luttringer <seblu@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
8 pkgdesc='A string search utility'
11 url='https://www.gnu.org/software/grep/'
13 depends=('glibc' 'pcre')
14 makedepends=('texinfo')
15 validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
16 source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
17 sha256sums=('5c10da312460aec721984d5d83246d24520ec438dd48d7ab5a05dbc0d6d6823c'
22 # apply patch from the source array (should be a pacman feature)
24 for src in "${source[@]}"; do
27 [[ $src = *.patch ]] || continue
28 msg2 "Applying patch $src..."
29 patch -Np1 < "../$src"
35 # configure option --without-included-regex removed in 3.7
36 # see: https://lists.gnu.org/archive/html/bug-grep/2021-08/msg00028.html
37 ./configure --prefix=/usr
48 make DESTDIR="$pkgdir" install