OCaml 4.14.0 rebuild
[arch-packages.git] / libunistring / trunk / PKGBUILD
bloba9892cf14e3f8248ce2c6515e682446daaf8506d
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Jan de Groot <jgc@archlinux.org>
4 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
5 # Contributor: Emmanuel 'guinness' Boudreault
6 # Contributor: Patrick McCarty <pnorcks at gmail dot com>
8 pkgname=libunistring
9 pkgver=1.0
10 pkgrel=1
11 pkgdesc='Library for manipulating Unicode strings and C strings'
12 url='https://www.gnu.org/software/libunistring/'
13 arch=(x86_64)
14 license=(GPL)
15 depends=(glibc)
16 provides=('libunistring.so')
17 source=(https://ftp.gnu.org/gnu/$pkgname/${pkgname}-${pkgver}.tar.xz{,.sig})
18 validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871'  # Daiki Ueno <ueno@unixuser.org>
19               '9001B85AF9E1B83DF1BDA942F5BE8B267C6A406D') # Bruno Haible (Open Source Development) <bruno@clisp.org>
20 sha256sums=('5bab55b49f75d77ed26b257997e919b693f29fd4a1bc22e0e6e024c246c72741'
21             'SKIP')
22 b2sums=('8208fe33d4ac2f015b0efb56b0c7dd87afc4bb1c6ca4eb3ded86d7e2101d7b7f68bfd8991af4b6dd408282ec73f134ee0b884e761ff6d52e8a1e398326aec420'
23         'SKIP')
25 prepare() {
26   cd $pkgname-$pkgver
27   # https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=cca32830b5
28   sed -i '/pragma weak pthread_create/d' tests/glthread/thread.h
31 build() {
32   cd $pkgname-$pkgver
33   ./configure --prefix=/usr
34   make
37 check() {
38   make -C $pkgname-$pkgver check
41 package() {
42   make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
45 # vim: ts=2 sw=2 et: