OCaml 4.14.0 rebuild
[arch-packages.git] / partitionmanager / kde-unstable / PKGBUILD
blobfd8e9e661fa98ee74af2526e6fc58d67e58ebc20
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Tobias Powalowski <tpowa@archlinux.org>
3 # Contributor: Nick B <Shirakawasuna at gmail _dot_com>
5 pkgname=partitionmanager
6 pkgver=22.07.90
7 pkgrel=1
8 pkgdesc='A KDE utility that allows you to manage disks, partitions, and file systems'
9 arch=(x86_64)
10 url='https://apps.kde.org/partitionmanager/'
11 license=(GPL2)
12 depends=(kpmcore hicolor-icon-theme kio)
13 makedepends=(extra-cmake-modules kdoctools)
14 groups=(kde-applications kde-system)
15 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('09a8d87d33226f47724795aa4f6f806e099a8ca3d91a9861486367aa6c5030ce'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 options=(debug)
23 build() {
24   cmake -B build -S $pkgname-$pkgver \
25     -DBUILD_TESTING=OFF
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build