1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Justin Davis <jrcd83@gmail.com>
7 pkgdesc='safe cleanup blocks'
9 url='https://metacpan.org/release/Guard'
10 license=('GPL' 'PerlArtistic')
12 options=('!emptydirs')
13 source=("https://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/Guard-${pkgver}.tar.gz")
14 md5sums=('dbbb944601a31f60ee58954ad4cb65b4')
17 ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
18 PERL_AUTOINSTALL=--skipdeps \
19 PERL_MM_OPT="INSTALLDIRS=vendor" \
20 PERL_MB_OPT="--installdirs vendor" \
21 MODULEBUILDRC=/dev/null
23 cd "${srcdir}/Guard-${pkgver}"
24 /usr/bin/perl Makefile.PL
30 ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
31 cd "${srcdir}/Guard-${pkgver}"
37 cd "${srcdir}/Guard-${pkgver}"
38 make DESTDIR="$pkgdir" install
45 # vim:set ts=2 sw=2 et: