OCaml 4.14.0 rebuild
[arch-packages.git] / perl-guard / trunk / PKGBUILD
blob88d929d8002918c6e5d434ae67e5e538c9c112d3
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Justin Davis <jrcd83@gmail.com>
4 pkgname=perl-guard
5 pkgver=1.023
6 pkgrel=13
7 pkgdesc='safe cleanup blocks'
8 arch=('x86_64')
9 url='https://metacpan.org/release/Guard'
10 license=('GPL' 'PerlArtistic')
11 makedepends=('perl')
12 options=('!emptydirs')
13 source=("https://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/Guard-${pkgver}.tar.gz")
14 md5sums=('dbbb944601a31f60ee58954ad4cb65b4')
16 build() {
17   ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""                 \
18       PERL_AUTOINSTALL=--skipdeps                            \
19       PERL_MM_OPT="INSTALLDIRS=vendor"     \
20       PERL_MB_OPT="--installdirs vendor" \
21       MODULEBUILDRC=/dev/null
23     cd "${srcdir}/Guard-${pkgver}"
24     /usr/bin/perl Makefile.PL
25     make
26   )
29 check() {
30   ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
31     cd "${srcdir}/Guard-${pkgver}"
32     make test
33   )
36 package() {
37     cd "${srcdir}/Guard-${pkgver}"
38     make DESTDIR="$pkgdir" install
41 # Local Variables:
42 # mode: shell-script
43 # sh-basic-offset: 2
44 # End:
45 # vim:set ts=2 sw=2 et: