OCaml 4.14.0 rebuild
[arch-packages.git] / python-ply / repos / extra-any / PKGBUILD
blob7d3b71d8088c026b9d40368415585997e849d322
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Alexander Rødseth <rodseth@gmail.com>
3 # Contributor: Marcin "avalan" Falkiewicz <avalatron@gmail.com>
4 # Contributor: C Anthony Risinger <anthony@xtfx.me>
6 pkgname=python-ply
7 pkgver=3.11
8 pkgrel=10
9 pkgdesc='Implementation of lex and yacc parsing tools'
10 arch=('any')
11 url='https://www.dabeaz.com/ply/'
12 license=('BSD')
13 depends=('python')
14 makedepends=('python-setuptools')
15 source=("https://pypi.io/packages/source/p/ply/ply-$pkgver.tar.gz"
16         LICENSE)
17 sha512sums=('37e39a4f930874933223be58a3da7f259e155b75135f1edd47069b3b40e5e96af883ebf1c8a1bbd32f914a9e92cfc12e29fec05cf61b518f46c1d37421b20008'
18             '5cea085a23ed260afc9084380c1d59e3942c2385089a8eb2391a89c85cde4df2ceb7eed21bb8c4d0cad5b78e59742da69e4c5c78fd0e223f5c99c56e9296a075')
20 check() {
21   cd "ply-$pkgver/test"
22   python testlex.py
23   python testyacc.py
26 package() {
27   cd "ply-$pkgver"
28   python setup.py install --root="$pkgdir"
30   install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
33 # vim:set ts=2 sw=2 et: