1 # Maintainer : Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
5 pkgname=python-pyopenssl
9 pkgdesc="Python3 wrapper module around the OpenSSL library"
10 url='https://github.com/pyca/pyopenssl'
12 depends=('python-cryptography')
13 makedepends=('python-setuptools')
14 checkdepends=('python-pytest' 'python-pretend' 'python-flaky')
15 source=(https://github.com/pyca/pyopenssl/archive/$pkgver/$pkgname-$pkgver.tar.gz)
16 sha512sums=('9e2aabdc4591662520320a22f75a3fa2d68576508f4c87a5a03ab1f14e02b099fbd054d72212ca6e780ee0146aae142365f7f79ec38557ceba0062ea72ee2178')
19 export LC_CTYPE=en_US.UTF-8
29 PYTHONPATH="$PWD"/build/lib pytest
34 python setup.py install --root="$pkgdir" --optimize=1 --skip-build