1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Qt HTTP Server'
12 depends=(qt6-websockets)
13 makedepends=(cmake ninja)
14 optdepends=('qt6-declarative: QML bindings')
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('8aca7185902d75aa06b0fac193888b357a59b9b2fe34c02f90bc115029a7b2f6')
22 cmake -B build -S $_pkgfn -G Ninja \
23 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
28 DESTDIR="$pkgdir" cmake --install build
30 install -d "$pkgdir"/usr/share/licenses
31 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname