OCaml 4.14.0 rebuild
[arch-packages.git] / qt6-wayland / kde-unstable / PKGBUILD
blob8b8f62ac7148fdd4199cca0460c6a81aeaa56527
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-wayland
6 _qtver=6.4.0-beta2
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Provides APIs for Wayland'
13 depends=(qt6-declarative libxcomposite)
14 makedepends=(cmake ninja)
15 groups=(qt6)
16 options=(debug)
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('d59238f3b54b859e9077471d2a9dfde77549e801da53d6eedfedc186b4286e2f')
21 build() {
22   cmake -B build -S $_pkgfn -G Ninja \
23     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build
30   install -d "$pkgdir"/usr/share/licenses
31   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname