OCaml 4.14.0 rebuild
[arch-packages.git] / telepathy-kde-accounts-kcm / trunk / PKGBUILD
blob44fbbc45837ef3e47f4c195ff1779842ed6b53b9
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Laurent Carlier <lordheavym@gmail.com>
5 pkgname=telepathy-kde-accounts-kcm
6 _pkgname=ktp-accounts-kcm
7 pkgver=22.04.3
8 pkgrel=1
9 pkgdesc='KCM Module for configuring Telepathy Instant Messaging Accounts'
10 arch=(x86_64)
11 url='https://community.kde.org/KTp'
12 license=(GPL)
13 groups=(kde-applications kde-network telepathy-kde)
14 depends=(telepathy-qt kaccounts-providers)
15 makedepends=(extra-cmake-modules intltool)
16 optdepends=('telepathy-gabble: XMPP/Jabber accounts support' 'telepathy-haze: account types supported by Pidgin/libpurple'
17             'telepathy-morse: Telegram accounts support' 'telepathy-salut: link-local XMPP account support')
18 source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig})
19 sha256sums=('a030fa874e9ed7a7a342027cd2e6643903532d4d1b828bf4c9ff3c6db1be35d3'
20             'SKIP')
21 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
22               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
23               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
24 options=(debug)
26 build() {
27   cmake -B build -S $_pkgname-$pkgver \
28     -DBUILD_TESTING=OFF
29   cmake --build build
32 package() {
33   DESTDIR="$pkgdir" cmake --install build