upgpkg: sbcl 2.2.5-1
[arch-packages.git] / liblangtag / trunk / PKGBUILD
blobc3d3dfaa305df6436e5991572c7b34de0ab7e592
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=liblangtag
4 pkgver=0.6.3
5 pkgrel=3
6 pkgdesc="interface library to access/deal with tags for identifying languages"
7 arch=('x86_64')
8 url="https://bitbucket.org/tagoh/liblangtag/wiki/Home"
9 license=('LGPL3' 'MPL') # actually MPL2.0
10 depends=('libxml2' 'glib2')
11 makedepends=('gobject-introspection')
12 optdepends=('gobject-introspection-runtime: use with liblangtag-gobject')
13 source=(https://bitbucket.org/tagoh/liblangtag/downloads/$pkgname-$pkgver.tar.bz2)
14 sha256sums=('1f12a20a02ec3a8d22e54dedb8b683a43c9c160bda1ba337bf1060607ae733bd')
16 build() {
17   cd "$pkgname-$pkgver"
18   ./configure --prefix=/usr
19   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
20   make
23 check() {
24   cd "$pkgname-$pkgver"
25   make -k check
28 package() {
29   cd "$pkgname-$pkgver"
30   make DESTDIR="$pkgdir/" install