1 # Maintainer: Laurent Carlier <lordheavym@gmail.com>
3 pkgname=xf86-video-amdgpu
6 pkgdesc="X.org amdgpu video driver"
8 url="https://xorg.freedesktop.org/"
10 depends=('systemd-libs' 'mesa')
11 makedepends=('xorg-server-devel' 'systemd' 'X-ABI-VIDEODRV_VERSION=25.2')
12 conflicts=('xorg-server<1.20.0' 'X-ABI-VIDEODRV_VERSION<25' 'X-ABI-VIDEODRV_VERSION>=26')
13 groups=('xorg-drivers')
14 source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.xz{,.sig})
15 sha512sums=('95c64e3fef7729ced6e7adc5e81c60cc218f6d8b6604f7b290e86ff52c917426b5102decbf8be8a66c9181ccde6e5dff7083dca8cc0c493a39e82625b5c7cb2a'
17 #validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # Michel Daenzer <michel@daenzer.net>
18 #validpgpkeys=('017E91A875CBA321258380F19B4EE4F98474DE40') # "Alex Deucher <alexdeucher@gmail.com>"
19 validpgpkeys=('F1111E4AAF984C9763795FFE4B25B5180522B8D9') # Shashank Sharma <contactshashanksharma@gmail.com>
22 cd ${pkgname}-${pkgver}
24 # Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
25 # With them, module fail to load with undefined symbol.
26 # See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
27 export CFLAGS=${CFLAGS/-fno-plt}
28 export CXXFLAGS=${CXXFLAGS/-fno-plt}
29 export LDFLAGS=${LDFLAGS/,-z,now}
31 #CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
33 ./configure --prefix=/usr \
39 cd ${pkgname}-${pkgver}
44 cd ${pkgname}-${pkgver}
46 make "DESTDIR=${pkgdir}" install
47 install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
48 install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"