archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kdenetwork-filesharing / repos / extra-x86_64 / PKGBUILD
blobc9f56a5bde523417f4aab039284dee842f86def2
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kdenetwork-filesharing
6 pkgver=21.12.1
7 pkgrel=1
8 pkgdesc='Properties dialog plugin to share a directory with the local network'
9 url='https://apps.kde.org/kdenetwork_filesharing/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-network)
13 depends=(samba kdeclarative)
14 makedepends=(extra-cmake-modules)
15 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('9e8dc8f6680d6477819df06d1cbbeac7313a15d308879e05ccd4578b3010e713'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
22 build() {
23   cmake -B build -S $pkgname-$pkgver \
24     -DBUILD_TESTING=OFF
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build