archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libvorbis / trunk / PKGBUILD
blob69b4b9d90f9e5778ae17f22a38bfb4babbd12c4b
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Tobias Kieslich <tobias@archlinux.org>
4 # Contributor: dorphell <dorphell@archlinux.org>
5 # Contributor: John Proctor <jproctor@prium.net>
7 pkgname=libvorbis
8 pkgver=1.3.7
9 pkgrel=2
10 pkgdesc='Reference implementation of the Ogg Vorbis audio format'
11 arch=(x86_64)
12 url=https://www.xiph.org/vorbis/
13 license=(BSD)
14 depends=(libogg.so)
15 makedepends=(git)
16 provides=(
17   libvorbis.so
18   libvorbisenc.so
19   libvorbisfile.so
21 _tag=0c55fa38933fd4bdb7db7c298b27e7bf2f2c5e98
22 source=(git+https://github.com/xiph/vorbis.git?signed#tag=${_tag})
23 validpgpkeys=(B7B00AEE1F960EEA0FED66FB9259A8F2D2D44C84) # Ralph Giles <giles@thaumas.net>
24 sha256sums=(SKIP)
26 pkgver() {
27   cd vorbis
29   git describe --tags | sed 's/^v//'
32 prepare() {
33   cd vorbis
35   ./autogen.sh
38 build() {
39   cd vorbis
41   ./configure \
42     --prefix=/usr \
43     --disable-static \
44     --enable-shared
45   make
48 check() {
49   make -C vorbis check
52 package() {
53   make DESTDIR="${pkgdir}" -C vorbis install
54   install -Dm 644 vorbis/COPYING -t "${pkgdir}"/usr/share/licenses/libvorbis
57 # vim: ts=2 sw=2 et: