archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt5-speech / trunk / PKGBUILD
blob57865c0074033d1bfb32ab62a6f6244a9f7c6ce9
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt5-speech
5 _qtver=5.15.2
6 pkgver=${_qtver/-/}
7 pkgrel=2
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Qt module to make text to speech and speech recognition easy'
12 depends=(qt5-multimedia)
13 makedepends=(flite speech-dispatcher)
14 optdepends=('flite: flite TTS backend' 'speech-dispatcher: speech-dispatcher TTS backend')
15 groups=(qt qt5)
16 _pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
17 source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
18 sha256sums=('c810fb9eecb08026434422a32e79269627f3bc2941be199e86ec410bdfe883f5')
19 options=(debug)
21 prepare() {
22   mkdir -p build
25 build() {
26   cd build
28   qmake ../${_pkgfqn}
29   make
32 package() {
33   cd build
34   make INSTALL_ROOT="$pkgdir" install
36   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
37   find "$pkgdir/usr/lib" -type f -name '*.prl' \
38     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
40   install -d "$pkgdir"/usr/share/licenses
41   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}