1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
9 url='https://www.qt.io'
10 license=('GPL3' 'LGPL3' 'FDL' 'custom')
11 pkgdesc='Provides platform-specific APIs for X11'
15 _pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
16 source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
17 sha256sums=('7014702ee9a644a5a93da70848ac47c18851d4f8ed622b29a72eed9282fc6e3e')
33 make INSTALL_ROOT="$pkgdir" install
35 # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
36 find "$pkgdir/usr/lib" -type f -name '*.prl' \
37 -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
39 install -d "$pkgdir"/usr/share/licenses
40 ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}