archrelease: copy trunk to extra-x86_64
[arch-packages.git] / squashfuse / repos / extra-x86_64 / PKGBUILD
blob2d961e3b1a016b054ccbc3367b1ee78bc085dd95
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=squashfuse
4 pkgver=0.1.104
5 pkgrel=2
6 pkgdesc="FUSE filesystem to mount squashfs archives"
7 arch=(x86_64)
8 url="https://github.com/vasi/squashfuse"
9 license=(custom)
10 depends=(fuse zstd)
11 makedepends=()
12 source=(https://github.com/vasi/squashfuse/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
13 sha256sums=('aa52460559e0d0b1753f6b1af5c68cfb777ca5a13913285e93f4f9b7aa894b3a')
15 build() {
16   cd $pkgname-$pkgver
17   ./configure --prefix=/usr
18   sed -e 's/ -shared / -Wl,-O1,--as-needed\0/g' -i libtool # Fix overlinking
19   make
22 package() {
23   cd $pkgname-$pkgver
24   make DESTDIR="$pkgdir" install
26   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
28 # install missing headers
29   install -Dm644 *.h -t "$pkgdir"/usr/include/squashfuse