archrelease: copy trunk to extra-x86_64
[arch-packages.git] / syndication / trunk / PKGBUILD
blob0ed33fb902a47345d5b1aaec02d15b60d52c4f56
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=syndication
4 pkgver=5.90.0
5 pkgrel=1
6 pkgdesc='RSS/Atom parser library'
7 arch=(x86_64)
8 url='https://community.kde.org/Frameworks'
9 license=(LGPL)
10 depends=(kcodecs)
11 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc)
12 groups=(kf5)
13 conflicts=(kde-syndication)
14 provides=(kde-syndication)
15 replaces=(kde-syndication)
16 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('bdfe30c05bbdd8e10903fe69a37cf859f25984edae16283fdd5c0ac207213229'
18             'SKIP')
19 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build