archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xf86-video-amdgpu / trunk / PKGBUILD
blob62d8ebfb6489f3ad7a1ef9ca163d7c6c6cbd509d
1 # Maintainer: Laurent Carlier <lordheavym@gmail.com>
3 pkgname=xf86-video-amdgpu
4 pkgver=21.0.0
5 pkgrel=2
6 pkgdesc="X.org amdgpu video driver"
7 arch=('x86_64')
8 url="https://xorg.freedesktop.org/"
9 license=('custom')
10 depends=('systemd-libs' 'mesa')
11 makedepends=('xorg-server-devel' 'systemd' 'X-ABI-VIDEODRV_VERSION=25.2')
12 conflicts=('xorg-server<1.20.0' 'X-ABI-VIDEODRV_VERSION<25' 'X-ABI-VIDEODRV_VERSION>=26')
13 groups=('xorg-drivers')
14 source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2{,.sig})
15 sha512sums=('44ccc8ddc36f09d1608cf58b6cf85dda090671c46c5643e9453f7d67f4d6850c3c9753eba43539d45773198b8042898a50153b5225780e4b2852410c5521314a'
16             'SKIP')
17 #validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # Michel Daenzer <michel@daenzer.net>
18 validpgpkeys=('017E91A875CBA321258380F19B4EE4F98474DE40') # "Alex Deucher <alexdeucher@gmail.com>"
20 build() {
21   cd ${pkgname}-${pkgver}
23   # Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
24   # With them, module fail to load with undefined symbol.
25   # See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
26   export CFLAGS=${CFLAGS/-fno-plt}
27   export CXXFLAGS=${CXXFLAGS/-fno-plt}
28   export LDFLAGS=${LDFLAGS/,-z,now}
30   #CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
32   ./configure --prefix=/usr \
33     --enable-glamor
34   make
37 check() {
38   cd ${pkgname}-${pkgver}
39   make check
42 package() {
43   cd ${pkgname}-${pkgver}
45   make "DESTDIR=${pkgdir}" install
46   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
47   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"