archrelease: copy trunk to extra-x86_64
[arch-packages.git] / yakuake / trunk / PKGBUILD
blobea65eb6a48fa482d5d16232fc558044cdb474394
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 # Contributor: James Rayner <iphitus@gmail.com>
5 # Contributor: leeghoofd <abcdefg@solcon.nl>
7 pkgname=yakuake
8 pkgver=21.12.1
9 pkgrel=1
10 pkgdesc='A drop-down terminal emulator based on KDE konsole technology'
11 arch=(x86_64)
12 url='https://apps.kde.org/yakuake/'
13 license=(GPL)
14 depends=(konsole kwayland hicolor-icon-theme)
15 makedepends=(extra-cmake-modules)
16 groups=(kde-applications kde-utilities)
17 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
18 sha256sums=('f41b97f155cff6b15fb8e4cbceb7e51010f090beaa9da0c7e0d0b215004722db'
19             'SKIP')
20 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
21               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
22               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
24 build() {
25   cmake -B build -S $pkgname-$pkgver \
26     -DBUILD_TESTING=OFF
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build