db-move: moved linux-zen from [testing] to [extra] (x86_64)
[arch-packages.git] / gnome-chess / repos / extra-x86_64 / PKGBUILD
blob23f5523773b6c01e094340262f53bef202429fbc
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-chess
5 pkgver=43.2
6 pkgrel=1
7 pkgdesc="Play the classic two-player boardgame of chess"
8 url="https://wiki.gnome.org/Apps/Chess"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(
12   gtk4
13   libadwaita
14   librsvg
16 makedepends=(
17   git
18   gobject-introspection
19   meson
20   vala
21   yelp-tools
23 optdepends=('gnuchess: Play against computer')
24 groups=(gnome-extra)
25 _commit=de47d07ec6fc828b2668ca6ee59fe9bdfa9dc1d6  # tags/43.2^0
26 source=("git+https://gitlab.gnome.org/GNOME/gnome-chess.git#commit=$_commit")
27 b2sums=('SKIP')
29 pkgver() {
30   cd $pkgname
31   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
34 prepare() {
35   cd $pkgname
38 build() {
39   arch-meson $pkgname build
40   meson compile -C build
43 check() {
44   meson test -C build --print-errorlogs
47 package() {
48   meson install -C build --destdir "$pkgdir"
51 # vim:set sw=2 sts=-1 et: