db-move: moved linux-zen from [testing] to [extra] (x86_64)
[arch-packages.git] / gnome-robots / trunk / PKGBUILD
bloba6057d0d68cf2f28684fd3ec45ec29d60e2d0729
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-robots
5 pkgver=40.0
6 pkgrel=1
7 pkgdesc="Avoid the robots and make them crash into each other"
8 url="https://wiki.gnome.org/Apps/Robots"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 gsound librsvg libgnome-games-support libgee)
12 makedepends=(meson gobject-introspection yelp-tools appstream-glib git vala)
13 groups=(gnome-extra)
14 _commit=6c9525c31e4ee08f2cb4e21d9d9de41850084fb4  # tags/40.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-robots.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   DESTDIR="$pkgdir" meson install -C build