db-move: moved linux-zen from [testing] to [extra] (x86_64)
[arch-packages.git] / gucharmap / repos / extra-x86_64 / PKGBUILD
blob1cceeb12961b4decdf442e00e8536e06c15465fb
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan De Groot <jgc@archlinux.org>
4 pkgname=gucharmap
5 pkgver=15.0.4
6 pkgrel=1
7 pkgdesc="Gnome Unicode Charmap"
8 url="https://wiki.gnome.org/Apps/Gucharmap"
9 arch=(x86_64)
10 license=(GPL3)
11 depends=(gtk3)
12 makedepends=(
13   appdata-tools
14   git
15   gobject-introspection
16   gtk-doc
17   meson
18   unicode-character-database
19   unzip
20   vala
21   yelp-tools
23 provides=(libgucharmap_2_90.so)
24 options=(!lto)
25 _commit=367f957574e7d7277839e7dfc3de6890937c4e2a  # tags/15.0.4^0
26 source=("git+https://gitlab.gnome.org/GNOME/gucharmap.git#commit=$_commit")
27 b2sums=('SKIP')
29 pkgver() {
30   cd $pkgname
31   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
34 prepare() {
35   cd $pkgname
38 build() {
39   local meson_options=(
40     -D b_lto=false
41     -D ucd_path=/usr/share/unicode
42   )
44   arch-meson $pkgname build "${meson_options[@]}"
45   meson compile -C build
48 check() {
49   meson test -C build --print-errorlogs
52 package() {
53   meson install -C build --destdir "$pkgdir"
56 # vim:set sw=2 sts=-1 et: