db-move: moved linux-zen from [testing] to [extra] (x86_64)
[arch-packages.git] / libcroco / trunk / PKGBUILD
blobdfe274e54f725a6af4b13b8cd7f55519a77f69ca
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
4 pkgname=libcroco
5 pkgver=0.6.13
6 pkgrel=2
7 pkgdesc="A CSS parsing library"
8 url="https://gitlab.gnome.org/GNOME/libcroco"
9 arch=(x86_64)
10 depends=(glib2 libxml2)
11 makedepends=(intltool git gtk-doc)
12 license=(LGPL)
13 _commit=7e15ca6c2c29a4b78367e6efa6195b331a92b2a7  # tags/0.6.13^0
14 source=("git+https://gitlab.gnome.org/GNOME/libcroco.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 prepare() {
23   cd $pkgname
24   NOCONFIGURE=1 ./autogen.sh
27 check() {
28   cd $pkgname
29   make check
32 build() {
33   cd $pkgname
34   ./configure --prefix=/usr --disable-static --enable-gtk-doc
35   make
38 package() {
39   cd $pkgname
40   make DESTDIR="$pkgdir" install