1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=libgnome-games-support-2
6 pkgdesc="Code shared between GNOME games"
7 url="https://gitlab.gnome.org/GNOME/libgnome-games-support"
11 makedepends=(vala git meson)
12 provides=("libgnome-games-support-${pkgver%%.*}.so")
13 _commit=75ed95f923d77705d5cb5eea14625a655a3225c8 # tags/2.0.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/libgnome-games-support.git#commit=$_commit")
18 cd libgnome-games-support
19 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 cd libgnome-games-support
27 arch-meson libgnome-games-support build
28 meson compile -C build
32 meson test -C build --print-errorlogs
36 meson install -C build --destdir "$pkgdir"